build.gradle 1.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. def localProperties = new Properties()
  2. def localPropertiesFile = rootProject.file('local.properties')
  3. if (localPropertiesFile.exists()) {
  4. localPropertiesFile.withReader('UTF-8') { reader ->
  5. localProperties.load(reader)
  6. }
  7. }
  8. def flutterRoot = localProperties.getProperty('flutter.sdk')
  9. if (flutterRoot == null) {
  10. throw new GradleException("Flutter SDK not found. Define location with flutter.sdk in the local.properties file.")
  11. }
  12. def flutterVersionCode = localProperties.getProperty('flutter.versionCode')
  13. if (flutterVersionCode == null) {
  14. flutterVersionCode = '1'
  15. }
  16. def flutterVersionName = localProperties.getProperty('flutter.versionName')
  17. if (flutterVersionName == null) {
  18. flutterVersionName = '1.0'
  19. }
  20. apply plugin: 'com.android.application'
  21. apply plugin: 'kotlin-android'
  22. apply from: "$flutterRoot/packages/flutter_tools/gradle/flutter.gradle"
  23. android {
  24. compileSdkVersion 29
  25. sourceSets {
  26. main.java.srcDirs += 'src/main/kotlin'
  27. }
  28. lintOptions {
  29. disable 'InvalidPackage'
  30. }
  31. defaultConfig {
  32. // TODO: Specify your own unique Application ID (https://developer.android.com/studio/build/application-id.html).
  33. applicationId "com.example.my_first_app"
  34. minSdkVersion 16
  35. targetSdkVersion 29
  36. versionCode flutterVersionCode.toInteger()
  37. versionName flutterVersionName
  38. multiDexEnabled true
  39. }
  40. buildTypes {
  41. release {
  42. // TODO: Add your own signing config for the release build.
  43. // Signing with the debug keys for now, so `flutter run --release` works.
  44. signingConfig signingConfigs.debug
  45. }
  46. }
  47. }
  48. flutter {
  49. source '../..'
  50. }
  51. dependencies {
  52. implementation "org.jetbrains.kotlin:kotlin-stdlib-jdk7:$kotlin_version"
  53. compile 'com.android.support:multidex:1.0.1'
  54. }